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1. MAK Data Logger First
Experience
Thank you for deciding to try out the MAK Data Logger. This first experience
with the Logger demonstrates how easy it is to record simulations, play them
back, and edit recordings.
Before you begin, install the software. Please see Install the Logger for instructions.

Prerequisites
To use the Logger, you need the following applications:
 A simulation source. The Logger records network traffic. To try out its

recording feature, you need something to record. If you have VR-Link, you
can use the talk or f18 applications. You could also use VR-Forces, MAK’s
CGF application. Or you could use any other simulation source that you
have that supports DIS or HLA.
 A viewing application, such as an IG or stealth. If you have VR-Link, you
can use the listen application or netdump to display the update messages
sent from the Logger. You could also use VR-Vantage, MAK’s 2D/3D viewer.
Or you can use some other application that you have that can display simulation messages that it receives over the network.
 If you want to use HLA, you need an RTI.
When you are ready, this guide will help you:
 Start the Logger.
 Record a Simulation.
 Play a Recording.
 Annotate a Recording.
 Edit a Recording.
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1.1. Start the Logger
The Logger supports DIS and HLA. Once you start the Logger, there is no difference in how it works between the two protocols. In this guide we use DIS and
also assume that you are running the Logger on Windows. If you are using
Linux, please refer to Logger Users Guide for the startup command.

³ To start the Logger, on the Windows 10 Start menu, choose MAK Technologies
→ Logger DIS (64 bit)). The Logger window opens (Figure 1-1).

The Logger window has menus for all features. It also has a toolbar with icons
for the common control operations. The icons mimic the icons on typical
recording and playback devices.

Figure 1-1. Logger window
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1.1.1. The Logger Window
To fully understand the Logger window, it will help to open a recording.
1. Choose File → Open. The Open File dialog box opens.
2. Select FollowSuspect-2019-DIS.lgr.
3. Click Open. The file is loaded (Figure 1-2).

Toolbars
Packet Count View

Packet Size View

Video Stream View
Annotations View

Zoom timeline
Playback range
Full timeline
Timeline cursor
Connection status
Listening status
Streaming video

Figure 1-2. Logger window with a Logger file loaded
The Logger window has a set of control icons, a timeline, and a status bar. The
Packet Count View and Packet Size View visually represent the data in the file.
The Annotations View lets you annotate a recording and quickly jump to annotated locations. If there is a video associated with the recording, you can view it
in the Video Stream View.
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The Logger window toolbar has the following buttons:

















1-4

Record.
Play.
Stop.
Pause.
Jump to Start. Move the timepoint (playback cursor) to the start of the
playback range.
Jump to End. Move the timepoint to the end of the playback range.
Decrease the playback speed (by 50%).
Current speed.
Increase the playback speed (double the speed).
Set the end of playback action (stop or wrap).
Enable video recording.
Jump to the previous annotation.
Insert a point annotation.
Insert a range annotation.
Extend the selected annotation.
Jump to the next annotation.
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1.2. Record a Simulation
When you record a simulation, the Logger reads packets off the network and
stores them in memory. When you are done recording, you save the data to a
file.
To record a simulation:
1. Start the Logger.
2. If it is not already running, start the simulation application that you want
to record.

i

By default, the Logger uses port 3000. If your simulation is using a
different port, you must either change the Logger’s port or the
simulation’s port. For details about changing connection parameters,
please see Chapter 4, Configuring the Logger Connection, in MAK Data
Logger Users Guide.
3. Choose Record → Record, or click the Record icon ( ) at the far left end of the
Logger toolbar. The Logger starts recording network traffic. As it does so, a
graph is displayed in the packet views. The blue lines show entity state
updates. The yellow lines show interactions.

Figure 1-3. New recording
4. When you are finished recording, choose Record → Stop, or click the Stop icon
( ) on the toolbar.
5. Choose File → Save. A Save dialog box opens.
6. Give the recording a name and click Save.
The saved recording will look similar to Figure 1-4. You can now play the
recording or edit it.
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Figure 1-4. Saved recording

1.3. Play a Recording
When you play a recording, you can simply play it from start to finish or you can
play it continuously. You can also choose to play only a portion of the file
1. If it is not still open, open the file you created in the previous section or load
one of the files included with the Logger.
2. Choose Play → Play/Pause, or click the Play icon ( ).
The Logger will start sending packets to the network. You can view the simulation in your IG or stealth application. You will need to load the appropriate
terrain in your viewer. If you are using the VR-Link talk utility or netdump to
view traffic, you will see a display of packet information in the console window.

1.3.1. Looping Playback
When the Logger plays a file to the end or the end of a playback range, it can
stop or it can loop back to the beginning of the file or range and start playing it
again.

³ To set the looping behavior, choose Play → Toggle Loop at End, or click the
Toggle Loop At End icon (
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1.3.2. Play a Segment of a File
You can configure the Logger to play any arbitrary segment of a file. If you have
the Logger configured to loop, it loops within the segment you have specified.
You can specify exact start and stop times in a dialog box or you can specify the
start and end times with the time sliders. In this guide we will show the time
sliders.
1. On the Logger timeline, drag the start time slider (Figure 1-5) to the time at
which you want to start playback. The Start time display in the Status Bar
shows the exact time that you select.

Playback segment
Start time slider
Double-click to
expand
End time slider

Figure 1-5. Timeline sliders
2. Drag the end time slider to the point on the timeline at which you want to
end playback. The Stop time display in the Status Bar shows the exact time
that you select.
3. Play the file. The timeline cursor will move between the start and end times.

Expand the Playback Segment to Full Length
³ To expand the playback segment to the full length of the file, drag the
sliders back to the edge of the window or double-click the timeline between
the start and end time sliders (Figure 1-5).
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1.4. Annotate a Recording
Logger files can be lengthy and if you wanted to be able to jump to particular
locations in a file, you could make a list of the important events and the times at
which they occur – or you could annotate the file. An annotation is associated
with a particular time or time range in a Logger file. Each annotation has a
name, and you can associate text with it. Besides being a way to store information about the events in a Logger file, annotations allow you to quickly bind
playback to a segment of a file.
The Logger has two kinds of annotations. Point annotations mark one point in
the timeline. Range annotations mark a range on the timeline.

1.4.1. Add a Point Annotation
1. Open the Logger file you recorded earlier.
2. Choose View → Annotations. The Annotations View is added to the Logger
window (Figure 1-6).

Figure 1-6. Annotations display
3. Click on the zoom timeline at the 20 second mark.
4. Choose Annotations → Create → Point Annotation. The Point Annotation dialog
box opens (Figure 1-7). The Time value in the dialog box matches the timepoint you selected in the zoom timeline.
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Figure 1-7. Range Annotation dialog box
5. In the Name text box, type a name for the annotation. The name is
displayed in the annotation view.
6. Optionally, in the Description box, enter any text that you want to accompany the annotation.
7. Click OK. The annotation is added to the display area (Figure 1-8).

Figure 1-8. New point annotation
8. Double-click the annotation marker. The Point Annotation dialog box opens.
You can read the description or edit the annotation.
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1.4.2. Add a Range Annotation
For this exercise, use the same Logger file you used when you added a point
annotation.
1. Click on the zoom timeline someplace to the right of the point annotation.
2. Choose Annotations → Create → Range Annotation. The Range Annotation dialog
box opens (Figure 1-7). The Time value in the dialog box matches the timepoint you selected in the timeline. Clicking in the timeline is not very exact,
so you can edit the time values in the dialog box if you want the start to be
exactly at a certain time.

Figure 1-9. Range Annotation dialog box
3. In the Name text box, type a name for the annotation.
4. The start point and end point for the range are currently the same. You can
set the end point in the dialog box, but there is an easier way to do it, so wait
a bit.
5. Click OK. The annotation is added to the display area (Figure 1-10).

Figure 1-10. New range annotation
6. Using your mouse, drag the right half of the range annotation marker to the
right. Now it looks like Figure 1-11.
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Figure 1-11. Finished range annotation

1.4.3. Save the Annotations
To save the annotations:
1. Choose Annotations → Save. The Save Annotation File dialog box opens.
2. Type a name for the annotation file.
3. Click Save. The next time you load the file, the annotations will also be
loaded.
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1.4.4. Use the Annotations
Now let’s use the annotations to navigate through the recording and control
playback.
1. Click the Jump to Start icon (
the file.
2. Click the Next Annotation icon (
tation.

) to move the time point to the beginning of
). The time point jumps to the point anno-

3. Click Next Annotation again. The time point jumps to the start of the range
annotation.
4. Choose Annotations → Select. The pull right menu lists all of the annotations
by name. Click A Point Annotation (or whatever you might have named it)
to jump back to the first annotation.
You can control playback by binding to a range annotation. This is like playing a
segment of a file, as you did earlier, except the Logger automatically sets the
bounds of the playback based on the range.
1. Select the range annotation.
2. Choose Annotations → Bound to Annotation. The Logger adjusts the timeline to
just play the range (Figure 1-12).

Figure 1-12. Bind to annotation
For more details about using annotations, please see Chapter 9, Annotating
Files, in MAK Data Logger Users Guide.
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1.5. Edit a Recording
You may want to edit Logger files to use for demonstrations, training, or other
purposes. The Logger lets you:
 Merge two files.
 Add a file to the beginning or end of another file.
 Clear a portion of a file of data and leave empty space.
 Delete a portion of a file.
 Trim dead space at the beginning of a file.
 Offset the timestamps of packets.

1.5.1. Append a File
For our first editing task, we will add one file to the end of another file.
1. Open the file you recorded at the start of this guide. Our example file is
called New Recording.lgr. (Substitute the names of your files in the
following steps.)
2. Choose File → Save As. Save the file to a different name, like New Recording
Two.lgr.
3. Close New Recording Two.lgr and open New Recording.lgr.
4. Choose Edit → Append File To End. The Append File To End dialog box opens.
5. Select New Recording Two.lgr.
6. Click Open. New Recording Two.lgr is added to the end of New
Recording.lgr. Figure 1-13 shows the concatenated files. The appended file
starts at around the one minute mark. If you examine the Packet Count
View, you can see where packets in the second half of the file duplicate those
in the first half.

Figure 1-13. Concatenated files
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7. Save the file to a new name. Use Save As so that you do not overwrite the
original file.

1.5.2. Clear Packets
In this second editing exercise, we will remove packets without changing the
length of the file. Use the concatenated file you created in the last section.
1. Drag the left timeline slider to the 45 second mark.
2. Drag the right timeline slider to the 0:01:15.00 mark. The window should
look like Figure 1-14. The gray areas are “masked”. They will not be
touched. The white section will be cleared.

Figure 1-14. Section to clear
3. Choose Edit → Clear Section. The packets between 1:30 and 2:30 are removed
(Figure 1-15). The other packets are not affected. The ones after the cleared
section maintain their original offset from the start of the recording. If you
play this file, there will be one minute of dead space.
(When you clear the segment, the Logger zooms in. Use the mouse scroll
wheel over the timeline to zoom out. Then drag the left side of the yellow
section of the timeline all the way to the left to see the entire packet view.
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Figure 1-15. Packets cleared
4. Choose File → Revert to undo the changes you made.
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1.5.3. Delete Packets
In this editing exercise, we will delete packets. When you delete packets, they
are removed and all packets in the file after them are offset to fill the space.
There are no gaps in the recording.
1. Drag the timeline sliders to the :45 and 1:15 marks as you did in the
previous exercise.

Figure 1-16. Section to clear
2. Choose Edit → Delete Section. The packets between :45 and 1:15 are removed
(Figure 1-17). The other packets have their time stamps changed and are
offset to fill in the missing time. Note that the file is now about 30 seconds
shorter than it was before the deletion.

Figure 1-17. Packets cleared
For more details about editing Logger files, please see Chapter 12, Editing
Logger Files, in MAK Data Logger Users Guide.
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A. Install the Logger

Your MAK salesperson has given you links to the Logger installer and the MAK
License Manager installer. Download the files. These instructions assume you
are familiar with installing Windows applications that use a wizard-style
installer.
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A.1. Install the Logger
³ To install the Logger, run the installer.

A.2. Setting Up the License Manager
To use a MAK product, you must install the MAK License Manager and get a
license for your product. Before you can use a MAK product, you must obtain a
valid license file and specify the license server.

³ To install the MAK License Manager, run the installer.
The general procedure for configuring license management is as follows:
1. Identify the name and ID of the license server and request a license file.
2. Put the license file in the MAK/MAKLicenseManager directory on the
license server.
3. Run the license server.
4. Specify the license server location.

A.2.1. Identify the Host ID and License Server Name
For simplicity, use the computer on which you installed Logger as the license
server. To find out the host ID and license server name:
1. On the Start menu, choose MAK Technologies → MAK License Manager. The MAK
License Manager utility opens (Figure A-1).

Figure A-1. License Manager
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2. Select the Request License tab. It displays the server name and the IDs for
your network cards.
3. If you have more than one network card, select the one that you want to use
as Host ID.
4. Send the host ID and hostname to your MAK salesperson. MAK will e-mail
you a license file.

A.2.2. Put the License File in the MAKLicenseManager Directory
When you receive your license file, put it in the MAKLicenseManager directory
on the license server. The file should have the extension .lic. If it does not,
please contact keys@mak.com to clarify why it did not follow this convention.

A.2.3. Run the License Server
³ To start the license server daemon, on the server machine only, execute
runLm from the MAKLicenseManager directory.

Shutting Down the License Server
³ To force all applications to check in their licenses and shut down the license
server daemon, run lmdown.

A.2.4. Specify the License Server
The first time you run a MAK application on a computer, the License Setup
dialog box opens (Figure A-2). It prompts you to enter the hostname of the
license server and optionally, a port number.
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Figure A-2. License Setup dialog box
1. Type the hostname in the Hostname box.
2. Click Add License Server. The application will start.
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